Feed on
Posts
Comments

Internet problems

I’ve been experiencing significant Internet problems during this cruise. These have typically been occuring the login process to the ship’s network. Once connected internet speed has been OK – not fast exactly, but good enough. But the login problems have become infuriating. As of this morning (Saturday 4 June) I haven’t been able to compete the login procedure at all – there’s been a “we are currently experiencing a high demand and cannot process your request – please try again in a few minutes” message after going through the process. This is really annoying and frustrating.

2 Responses to “Internet problems”

  1. Mick Sherwood says:

    Thanks for the review, excellent.. This was our 5th trip on the Ventura and really enjoyed it. I took a laptop with a view to ‘Skype-ing’ back home to see our new granddaughter which we had done before with no problem. It was so frustrating. It was obvious that there was no satellite connection the first week and could only use in port. We got through in Malaga for 10 minutes and that was it. I complained on the Sunday morning and was told it wasn’t for Skype, only emails etc. ??? I asked for money back – no, front desk – no. So I wrote to the Media Manager. He called and apologised and I got a refund. He said they had problems sourcing sufficient band-width this trip and that I should check before buying in future what was available. I certainly shall. It’s been my only gripe ever with P&O but it wont stop me going again.
    Thanks again.

    • tomtotley says:

      Mick: thanks for your comment. I too was getting very unhappy at the end of the first week. However over that weekend (from the time we were in Venice onwards it suddenly improved dramatically, and I had excellent service from then on.

      I was using an iPad (first version). I found very good wifi reception in the public areas on decks 5, 6 & 7 but no-where else.

Leave a Reply

%d bloggers like this: